قسمت نهم آموزش voip سیسکو

قدم اول ، آماده سازی مقدمات برای راه اندازی مرکز تلفن CME

برای این که درک درستی از روند کار داشته باشید در قدم اول تصویر سناریو را مشاهده نمایید

همانطور که میبینید در طبقه یک و دو یک تلفن و یک PC وجود دارد که VLAN هر کدام در کنار آن نوشته شده است . هدف ما این است که :
1 . هر دستگاه در VLAN خود قرار گیرد .
2 . با DHCP به همه تجهیزات IP بدهیم .
3 . PC ها یکدیگر را پینگ کنند .
4 . پس از راه اندازی CME فایل کانفیگ تلفنها ساخته شده و تلفنها رجیستر شوند .
5 . در آخر تلفنها با یکدیگر تماس بگیرند .
ابتدا روی سوییچها VLAN های مورد نظر را به کمک کامندهای مربوطه میسازیم

سوییچ طبقه 1و2و 3


switch> enable

switch# configure terminal

switch(config) vlan 10

switch(config-vlan) name pc-f1

switch(config-vlan) vlan 20

switch(config-vlan) name pc-f2

switch(config-vlan) vlan 30

switch(config-vlan) name voice

حال همانطور که قبلا گفتیم باید پورتهای هر VLAN را عضو VLAN مربوطه نموده و آنها را در حالت Access قرار دهیم . سپس برای عبور ترافیک تمام VLAN ها به سمت روتر ، لینک بین سوییچ طبقه اول و سوم ، سوییچ طبقه دوم و سوم ، سوییچ طبقه سوم و روتر را از نوع ترانک قرار میدهیم

سوییچ طبقه ۱


switch(config) interface fastethernet 0/1

switch(config-if) switchport mode access

switch(config-if) switchport access vlan 10

switch(config-if) switchport voice vlan 30

switch(config-if) interface fastethernet 0/2

switch(config-if) switchport mode trunk

سوییچ طبقه ۲


switch(config) interface fastethernet 0/1

switch(config-if) switchport mode access

switch(config-if) switchport access vlan 20

switch(config-if) switchport voice vlan 30

switch(config-if) interface fastethernet 0/2

switch(config-if) switchport mode trunk

سوییچ طبقه ۳


switch(config) interface fastethernet 0/3

switch(config-if) switchport mode trunk

حال پورت روتر را روشن نموده و IVR یا Inter VLAN Routing را روی آن پیاده سازی میکنیم. Inter VLAN Routing یکی از مباحث دورهی CCNA R&S میباشد . همانطور که میدانید به صورت پیش فرض هیچ ارتباطی بین VLAN های مختلف وجود ندارد مگر این که Inter VLAN Routing پیاده سازی شده باشد . به کمک این قابلیت میتوان توسط روتر ترافیک VLAN های مختلف را به یکدیگر ارسال نمود . اگر به کامندهای ذیل دقت کنید متوجه میشوید که ابتدا وارد Sub Interface ها میشویم و پس از فعالسازی 1q . روی پورت ، یک IP نیز به آن اختصاص میدهیم

روی روتر


Router> enable

Router# configure

Router(config)# interface fastEthernet 0/0

Router(config-if)# no shutdown

Router(config-if)# exit

Router(config)# int fastEthernet 0/0.10

Router(config-subif)# encapsulation dot1Q 10

Router(config-subif)# ip address 192.168.10.1 255.255.255.0

Router(config-subif)# int fastEthernet 0/0.20

Router(config-subif)# encapsulation dot1Q 20

Router(config-subif)# ip address 192.168.20.1 255.255.255.0

Router(config-subif)# int fastEthernet 0/0.30

Router(config-subif)# encapsulation dot1Q 30

Router(config-subif)# ip address 192.168.30.1 255.255.255.0

حال نوبت به یکی از مهمترین قدمهای راه اندازی CME یعنی DHCP میرسد . در این بخش میخواهیم روی روتر طبقهی سوم سرویس DHCP را راهاندازی نماییم . همانطور که مشاهده میکنید برای تلفنها آدرس TFTP سرور با Option 150 را نیز معرفی کرده ایم

روی روتر


Router(config)# ip dhcp pool f1-data

Router(dhcp-config)# network 192.168.10.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.10.1

Router(config)# ip dhcp pool f2-data Router(dhcp-config)# network 192.168.10.20.0 255.255.255.0


Router(dhcp-config)# default-router 192.168.20.1

Router(config)# ip dhcp pool voice

Router(dhcp-config)# network 192.168.30.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.30.1

Router(dhcp-config)# option 150 ip 192.168.30.1

پس از طی کردن مراحل فوق به هر یک از تجهیزات یک IP اختصاص داده میشود ( ۱۹۲٫۱۶۸٫۱۰٫۲ به PC طبقه اول و ۱۹۲٫۱۶۸٫۲۰٫۲ به PC طبقه دوم اختصاص داده شده است ) . همانطور که در تصویر ذیل میبینید کامپیوترها نیز به سادگی میتوانند یکدیگر را پینگ کنند

قدم دوم ، راه اندازی CME

قبل از این که کامندها را بررسی کنیم به دو تعریف ذیل دقت کنید :

1 . Ephone-dn : به طور خلاصه و ساده ، یک داخلی است که برای تلفنها تعریف میکنیم و برای آن یک شماره ی داخلی نیز انتخاب میکنیم. Ephone-dn ها میتوانند Single یا Dual باشد که اولی فقط یک تماس را پردازش میکند ولی حالت دوم میتواند سرویس پشتخطی یا کنفرانس تماس را نیز پشتیبانی نماید .
2 . Ephone : منظور تلفنی است که به صورت فیزیکی استفاده میکنیم .
در سناریویی که در حال انجام آن هستیم از روتر ۲۸۱۱ سیسکو برای راه اندازی CME استفاده شده است. برای راه اندازی مرکز تلفن CME و رجیستر شدن تلفنها باید کامندهای ذیل را روی روتر وارد نماییم

روی روتر


Router(config)# telephony-service

Router(config-telephony)# ip source-address 192.168.30.1 port 2000

Router(config-telephony)# max-ephones 10

Router(config-telephony)# max-dn 10

Router(config-telephony)# auto assign 1 to 10

Router(config-telephony)# auto-reg-ephone

Router(config-telephony)# create cnf-files

توضیح کامندها :
1 . ابتدا وارد تلفن سرویس شده ایم .
2 . آدرس مرکز تلفن و پورت را مشخص میکنیم .
3 . ماکزیمم تعداد تلفنها را مشخص میکنیم .
4 . ماکزیمم تعداد داخلیها را مشخص میکنیم .
5 . تعیین میکنیم که داخلی ۱ تا ۱۰ به صورت خودکار به تلفنها اختصاص داده شود .
6 . تعیین میکنیم که تلفنها به صورت خودکار شناسایی شوند .(در غیر این صورت باید تک به تک به تنظیمات تلفنها در روتر رفته و مک آدرس آنها را ثبت کنیم . )
7 . درخواست ساخت فایل کانفیگ در سرور را ارسال میکنیم .
در آخر باید برای هر یک از Ephone-dn ها یک شماره داخلی تعیین نماییم

روی روتر


Router(config)# ephone-dn 1

Router(config-ephone-dn)# number 1000

Router(config-ephone-dn)# ephone-dn 2

Router(config-ephone-dn)# number 2000

حال همانطور که در تصویر فوق مشاهده میکنید با گرفتن شماره داخلی تلفن طبقه ی دیگر ، تلفن شروع به زنگ خوردن میکند .
سناریوی عملی راه اندازی مرکز تلفن CME در همین نقطه به پایان میرسد . بدیهی است که سناریوی فوق یک مثالی کوچک از امکانات و قابلیتهای تجهیزات سیسکو میباشد و علاقهمندان به یادگیری باید برای آشنایی هرچه بیشتر با مراکز تلفنی سیسکو سناریوهای متعدد راه اندازی کرده و حالتهای گوناگون آن را آزمایش و بررسی نمایند .

پاسخ دهید

آدرس ایمیل شما منتشر نخواهد شد. فیلدهای اجباری مشخص شده اند *
شما می توانید از این تگ های HTML و ویژگی ها استفاده کنید: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>